201510060946HP A5120 交換器 switch 基本設定

 就因為「終身保固」加上只是要一台純 Layer-2 的 switch 簡單需求,所以購買了一台 HP A5120 交換器。從 console 進入後發現他的設定/操作 模式跟一般類 cisco 的交換器不太一樣(讓我想起N年前的  Xylan ),底下就簡單記錄一下設定的方法。

HP 5120-24G SI 官方網址:http://www8.hp.com/tw/zh/products/networking-switches/product-detail.html?oid=4174791
說明文件:http://h17007.www1.hp.com/device_help/H3C-Manuals/5120/5120-Configuration-Guide(R2215).pdf

這台一萬多的交換器(不含GBIC),管理介面有 Web、Console、telnet ,預設從  console 連進去是不用密碼的,而 Web 管理介面是預設連不到(因為還沒設定IP跟帳號),所以最基本的你必須先以 console 連入,給予 Default VLAN 一個IP,然後設定帳號(自取)與密碼(自取)。

--- 基本說明 ---------------------------

★★ 在 HP switch 的權限分為 0:拜訪、1:監督、2:系統、3:管理,要以「super」指令來進行變更,假設要進入到管理權限則執行「super 3 」。除非貴公司針對網路設備要給予不同人不同的管理權,不然直接進入 Level-3 設定就是了。
<HP_sw>super 3
User privilege level is 3, and only those commands can be used
whose level is equal or less than this.
Privilege note: 0-VISIT, 1-MONITOR, 2-SYSTEM, 3-MANAGE

★★ 進入設定層級要執行「system-view」,如 Cisco 的 「enable」指令
  ==> 提示符號會變成中括弧    由 <ooo>  ->  [ooo] 

簡單的指令對照可以參考下圖

--- 各項設定項目 ---------------------------------------------------------

★進入 Default VLAN ,給予交換器設定IP★ 
★儲存設定值★
★設定交換器名稱★ 
★新增帳號與密碼,並給予連入的權限★ 
★啟動 web 管理介面★ 
★設定預設閘道器 Default Router, Gateway★ 
★設定 Terminal / Console 登入密碼★ 
★設定ACL限制可以連入的IP★ 
Step1:新增一個 acl
Step2:增加規則 IPs 到 ACL
Step3:配置ACL到 interface
-----------------------------------------------------------------

★進入 Default VLAN ,給予交換器設定IP★ 
預設交換器就會有一個 Default VLAN (vlan id=1)
<OO> system-view
[OO] interface Vlan-interface 1
[OO-Vlan-interface1] ?


[OO-Vlan-interface1]ip address ?
X.X.X.X IP address
bootp-alloc IP address negotiated with BOOTP
dhcp-alloc IP address negotiated with DHCP

設定此VLAN的IP位址,當然~~如果你的多個VLAN都要設定IP,也可以使用相同的方法設定之。
ip address your_IP  your_ip_NetMask
[OO-Vlan-interface1]ip address 10.1.1.1 255.255.255.0

註:在 system-view 模式下,有另一個指令「[OO]ip host host_name host_ip」,但管理介面是應該設定在 Vlan 內的。

★儲存設定值★ 
指令 save 
在不同的層級內都可以做此儲存,當然前提示你的帳號權限要有夠的權限  Level
<OO>save
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):
flash:/startup.cfg exists, overwrite? [Y/N]:y
Validating file. Please wait....
Saved the current configuration to mainboard device successfully.
Configuration is saved to device successfully.

★設定交換器名稱★ 
指令 sysname
<OO>system-view
System View: return to User View with Ctrl+Z.
[OO]sysname ?
TEXT Host name (1 to 30 characters)
[OO]sysname God
[God]  <-- 提示名稱換成你所設定的 God

★新增帳號與密碼,並給予連入的權限★ 
指令:local-user                                         // 底下斜線後的為註解,非執行指令
local-user admin                                        // 新增帳號 admin
password cipher xxxxxxxxx                       // 設定密碼 xxxxx,當然你要把 xxx 換成你要設定的密碼
authorization-attribute level 3                   // 給予 Priority Level-3 的權限
service-type telnet terminal                      // 給予 telnet 跟 console 登入的權限
service-type web                                      // 給予 web 管理的存取權限
// 不過 admin 並不是好帳號,對於管理介面是最先被測試的(被TRY密碼)


★啟動 web 管理介面★ 
[God] system-view
[God]ip http ?
acl         Specify acl filtering
enable   Start http server
port       Specify port
[God]ip http enable                                 // 啟動  web 服務
[God]ip http port ?
INTEGER<1-65535> Port number
[God]ip http port 8080                            // 指定 web 服務運作在連接埠 port: 8080

★設定預設閘道器 Default Router, Gateway★ 
如果你只是要他當個純 Layer-2 Switch ,也不會從遠端連線過來,那你是可以不用設定這個選項
[God] ip route-static 0.0.0.0 0.0.0.0 Vlan-interface1  your_gateway_ip


★設定 Terminal / Console 登入密碼★ 
[God]user-interface ?
INTEGER<0-35> First user terminal interface number to be configured
aux Aux user terminal interface
vty Virtual user terminal interface
[God]user-interface vty ?
INTEGER<0-15> First user terminal interface number to be configured
[God]user-interface vty 0 ?
INTEGER<1-15> Last user terminal interface number to be configured
<cr>
[God]user-interface vty 0 4
[God-ui-vty0-4]

//授與權限等級
[God-ui-vty0-4]user privilege level 3
//設定密碼
[God-ui-vty0-4]set authentication password cipher xxxxxx

★設定ACL限制可以連入的IP★ 
Step1:新增一個 acl
<God>system-view
// 開始設定 acl 2020 的內容
[God]acl ?
copy        Specify a source acl
ipv6        IPv6 acl
name      Specify a named acl
number   Specify a numbered acl
[God]acl number 2020 name ip_limit
[God-acl-basic-2020-ip_limit]?
Acl-basic view commands:
description    Specify ACL description
display          Display current system information
logfile           Specify log file configuration
ping              Ping function
quit              Exit from current command view
return           Exit to User View
rule              Specify an acl rule
save             Save current configuration
step              Specify step of acl sub rule ID
tracert          Trace route function
undo             Cancel current setting

Step2:增加規則 IPs 到 ACL
// 利用指令 rule 來為此 acl 增加規則
[God-acl-basic-2020-web_limit]rule ?
INTEGER<0-65534> ID of acl rule
deny       Specify matched packet deny
permit     Specify matched packet permit
remark    Specify Rule Remark
// 請注意這裡 netmask 所用的 wildcard 跟 CIDR 用法並不一樣,以單一 IP 為例  CIDR為32 ,在這  wildcard 要用 0
[God-acl-basic-2020-web_limit]rule permit source 10.1.1.1 ?
0             Wildcard bits : 0.0.0.0 ( a host )
X.X.X.X    Wildcard of source
[God-acl-basic-2020-web_limit]rule 3001 permit source 10.1.1.1 0 
[God-acl-basic-2020-web_limit]rule 3002 permit source 10.1.1.2 0 
// 需要增加幾個IP就增加幾行吧
// 若是要增加一個 class-C 範圍,其 netmask 要用 0.0.0.255

Step3:配置ACL到 interface
<God>system-view
System View: return to User View with Ctrl+Z.
[God]user-interface vty 5 15
[God-ui-vty5-15]acl ?
INTEGER<2000-3999> Apply basic or advanced acl
INTEGER<4000-4999> Apply ethernet frame header acl
ipv6 Specify the ipv6 acl filtering
// 要設定IP連入限制,只需要用 basic acl ,所以 rule id 要選用 2000~3999 間的數字,不能重複使用
[God-ui-vty5-15]acl 2020 inbound
[God-ui-vty5-15]return
[God]user-interface vty 0 4
[God-ui-vty0-4]acl 2020 inbound
[God-ui-vty0-4]return
// 限制 web 介面
[God]ip http acl 2020

--------------------------------------------------------------

Web 介面

Web 操作就請大家自己試試看囉

~END

  • 網路埠的編號  slot/moduleID/port number    例如: GigabitEthernet1/0/24
  • 顯示目前層級的設定:display this
  • 往外跳一層:quit
  • 一次移除一個範圍的vlan: undo vlan 2 to 4094
  • 做 link aggregation,以光纖模組的 port 25,26 trunk 為例
    [God]interface Bridge-Aggregation ?
    <1-26> Bridge-Aggregation interface number
    [God]interface Bridge-Aggregation 1
    [God-Bridge-Aggregation1]link-aggregation mode dynamic
    [God-Bridge-Aggregation1]quit
    [God]interface GigabitEthernet 1/0/25
    [God-GigabitEthernet1/0/25]port link-aggregation group 1
    [God-GigabitEthernet1/0/25]quit
    [God]interface GigabitEthernet 1/0/26
    [God-GigabitEthernet1/0/26]port link-aggregation group 1
    [God-GigabitEthernet1/0/26]quit
    [God]interface Bridge-Aggregation 1
    [God-Bridge-Aggregation1]port link-type trunk
    [God-Bridge-Aggregation1]port trunk permit vlan all
    Please wait........................................... Done.
    Configuring GigabitEthernet1/0/25........................................... Done.
    Configuring GigabitEthernet1/0/26........................................... Done.
    但要注意唷!這樣的指令下法,其VLAN是不包含  VLAN 1 唷 2-4094




回應
關鍵字
Google Search
Google
累積 | 今日
loading......
平均分數:0 顆星
投票人數:0
我要評分:
Google